Portal Home > Knowledgebase > Joomla > Joomla Security Upgrade Required


Joomla Security Upgrade Required




If you have a Joomla site, check if your installed  Joomla version is one of Joomla 1.0.*/1.5.x seres or is earlier of the actual mainstream Joomla 2.5.17.

The 1.5.x version has been deprecated by Joomla for over a year, and the Joomla 1.0.* series is unsupported for more, than 4 years, with no official updates (including no security updates). Without continued maintenance from the Joomla team, your current installation has extensive security vulnerabilities. This means that your site can be easily hacked by any hacker with minimal skills.

Because your site security is also important to us, we highly recommend migrating to the most recent Joomla branch. Unfortunately, if your site is found to be compromised then we will have to suspend your services through us until the problem has been corrected. Throughout next week we will be migrating users found to be using Joomla less than 2.5.17, to 2.5.17. We strongly encourage you to perform the upgrade ahead of schedule to avoid any possible unforeseen issues.

The current stable and secure version of Joomla is 2.5.17. For instructions on how to migrate to the newest version, see the Joomla documentation:

http://docs.joomla.org/J2.5:Migrating_from_Joomla_1.5_to_Joomla_2.5

The migration process is targeted to standard Joomla 1.5 installations, which will cover the majority of users. If you have custom themes or code they may not be compatible with the recommended upgrade process.

There is also a Joomla Extension jUpgrade that can assist with your update from Joomla 1.5 to Joomla 2.5.17:

http://extensions.joomla.org/extensions/migration-a-conversion/joomla-migration/11658

For upgrading installations from 1.7+ to 2.5.17, please follow these instructions:

http://docs.joomla.org/J2.5:Upgrading_from_an_existing_version

All of these upgrade options may not work in some circumstances where a custom template or plugin is in use.

Finally, for best results on all Joomla installations, we recommend reviewing and following the Joomla security guidelines:

http://docs.joomla.org/Security

Please migrate to the latest version (currently 2.5.17) as soon as possible to avoid any delays or interruptions to your site functions. Thank you for your attention in this matter and please feel free to contact us if you have questions or concerns.


Are you searching a Dedicated Web Hosting Server, Manak Hosting Best Servers Plans available for you Click here to visit www.manakhosting.com

Was this answer helpful?

Add to Favourites Add to Favourites    Print this Article Print this Article

Also Read
Joomla Tips (Views: 1124)
Joomla caching (Views: 707)
Joomla 3.5 is here (Views: 458)

Powered by WHMCompleteSolution